Art of Mathematics

Aufgabe: Man soll die folgende geometrische Erklärung nachprüfen.

„Art of Mathematics“ ist eine Facebookseite, die mir sehr gut gefällt. Es gibt Ideen,  die für die Anwendung von CAS Maxima sehr gut geeignet sind. Neuerdings gibt es auch http://www.artmathematics.com

art-of-mathematics

Rückrechnung: http://maxima-online.org/?inc=r1753546365

Ohne Computer Algebra ließe sich das natürlich auch lösen, allerdings mit erheblichem Rechenaufwand: Partialsummenfolgen bilden und daraus das Polynom vierten Grades berechnen. Die Vorgangsweise können wir mit CAS Maxima skizzieren.

Die Partialsummenfolge der linken Seite:

li-partialsumme

Code:

f(x):=sum(k^3,k,1,x);
X:makelist(k,k,1,5);
Y:map(f,X);
g(x,y):=y=a*x^4+b*x^3+c*x^2+d*x+e;
Gleichung:map(g,X,Y);
Loesung:solve(Gleichung,[a,b,c,d,e]);
Ergebnis:g(x,y),Loesung;
Bildungsgesetz:rhs(Ergebnis),x=n;

Die Partialsummenfolge der rechten Seite:

re-partialsumme

Code:

f(x):=(sum(k,k,1,x))^2;
X:makelist(k,k,1,5);
Y:map(f,X);
g(x,y):=y=a*x^4+b*x^3+c*x^2+d*x+e;
Gleichung:map(g,X,Y);
Loesung:solve(Gleichung,[a,b,c,d,e]);
Ergebnis:g(x,y),Loesung;
Bildungsgesetz:rhs(Ergebnis),x=n;

Mit Geogebra kann man auch etwas machen!

Auswahl_006.png

Geogebra Datei dazu

In EXCEL kann man die Partialsummen-Folge durch Formel-Kopieren erreichen, in der Geogebra-Tabellenkalkulation habe ich gemogelt.

k k hoch 3 Partialsummen
1 =A2^3 =SUMME($B$2:B2)
2 =A3^3 =SUMME($B$2:B3)
3 =A4^3 =SUMME($B$2:B4)
4 =A5^3 =SUMME($B$2:B5)
5 =A6^3 =SUMME($B$2:B6)

Über Johnny Weilharter

Direktor i. R. der Bundeshandelsakademie und Bundeshandelssschule in Tamsweg, Österreich
Dieser Beitrag wurde unter benutzerdefinierte Funktion, BYOD, Creative Commons, Folgen, FUNKTIONEN, GEOGEBRA, GeoGebra CAS, GLEICHUNGEN ODER GLEICHUNGSSYSTEME, Kompetenzorientiert, Listenverarbeitung, Literaturhinweis, Programmiersprache, Reihen, Summen, ZUSAMMENARBEIT veröffentlicht. Setze ein Lesezeichen auf den Permalink.